Calcular el recíproco de un número

De Wiki
Saltar a: navegación, buscar
  • Descripción: Pregunta al usuario un número, para luego calcular el recíproco del mismo.
  • Variables: Numero (ingresado por el usuario)
  • Publicado Por: Miguel González Aravena.
  • Editado por: El Lobo
  • Soporte: Comente fallas del codigo en la discusión de esa pagina
  • Código para Pseudocódigo:

[editar] ¿Reciproco?

Un reciproco tambien conocido como la inversa multiplicativa, es un numero que al ser multiplicado por su inverso (que siempre es 1 dividido por el numero en si) da 1. El cero no tiene reciproco debido a una division por cero (Ej: El Numero es: 2, su reciproco es 1/2)

[editar] Codigos

Programa Reciproco
{El programa pregunta el usuario un número, para luego calcular su recíproco.}
{Numero es una variable de tipo entero.}

Inicio
1.	Escribir "Ingrese un numero: "
2.	Leer Numero
3.      Si Numero=0
4.          Escribir "Cero no tiene reciproco"
5.      Sino
6.	   Escribir "El reciproco de ", Numero, " es ", (1/Numero)
7.	   Escribir "El reciproco de ", Numero, " en fraccion es 1/", Numero
8.       Fin condicional Si
Fin_programa

A continuación, el código para PSeINT:

Proceso Reciproco
	Definir Numero Como Entero;
	Escribir "Ingrese un numero: ";
	Leer Numero;
        Si Numero=0
           Escribir "Cero no tiene reciproco"
        Sino
	   Escribir "El reciproco de ", Numero, " es ", (1/Numero); // Calculamos el reciproco.
	   Escribir "El reciproco de ", Numero, " en fraccion es 1/", Numero; // Lo convertimos a fraccion.
        FinSi
FinProceso

  • Publicado Por: Daniel Arenas

Pseudocodigo:

Programa Reciproco
        {n es una variable de tipo real}
Inicio
      Escribir "Ingrese un numero"
      Leer n
      Si n <> 0 Entonces
           Escribir "El reciproco de este numero es : ", (1/n)
      Sino
           Escribir "El cero no tiene reciproco"
      {fin condicional si}
Fin

PseINT:

Proceso Reciproco
	definir n Como Real;
	Escribir "ingrese un numero";
	leer n;
	Si n <> 0 Entonces
		Escribir "El reciproco del numero es: ", (1/n);
	Sino
		Escribir "El cero no tiene reciproco";
	FinSi
	
FinProceso

  • Publicado por Felipe Ascencio.

Código en Pseudocodigo:

Inicio
	hacer k<-1
	mientras k=1 Hacer
		
		Escribir "Ingrese un numero"
		Leer num
		Escribir "El reciproco de ", num, " es", (1/num)
		Escribir "Pulse 1 si desea conocer el reciproco de otro numero"
		Escribir "Pulse 2 si desea salir"
		Leer a
		si a= 1 Entonces
			hacer k<-1
		Sino
			hacer k<-2
		{Fin condicional si}
	{Fin ciclo mientras}
Fin

Código en PSeInt:

Proceso reciproco
	k<-1;
	mientras k=1 Hacer
		
		Escribir "Ingrese un numero";
		Leer num;
		Escribir "El reciproco de ", num, " es", (1/num);
		Escribir "Pulse 1 si desea conocer el reciproco de otro numero";
		Escribir "Pulse 2 si desea salir";
		Leer a;
		si a= 1 Entonces
			k<-1;
		Sino
			k<-2;
		FinSi
	FinMientras
FinProceso

  • Publicado Por: Morynne Fredz.

Pseudocódigo:

Programa Reciproco_de_un_Numero
{num es una variable de tipo entero}

Inicio
1.	Escribir "Ingrese un numero"
2.	Leer num
3.      Si Numero=0
4.         Escribir "Cero no tiene reciproco"
5.      Sino
6.	   Escribir "El reciproco del Numero en fraccion es de:  (1/", num, ")"
7.	   Escribir "El reciproco del Numero es de: ", (1/num)
8.      Fin Condicional Si
Fin_programa

En PSeINT:

1. Proceso Reciproco_de_un_Numero
2. 	Definir num Como Entero;
3. 	Escribir "Ingrese un numero: ";
4. 	Leer num;
5.      Si Numero=0
6.         Escribir "Cero no tiene reciproco"
7.      Sino
8. 	 Escribir "El reciproco del Numero en fraccion es de:  (1/", num, ")";
9. 	 Escribir "El reciproco del Numero es de: ", (1/num);
10.      FinSi
   FinProceso

Herramientas personales
Espacios de nombres

Variantes
Acciones
Navegación
Herramientas
Imprimir/exportar